Yawcam 0.7.0 won't start on Windows XP

Report and discuss bugs here!
Post Reply
Mr Wolf
Posts: 10
Joined: Mon Mar 31, 2008 10:28 pm

Yawcam 0.7.0 won't start on Windows XP

Post by Mr Wolf » Thu May 20, 2021 5:13 pm

Ok, I know Windows XP is not - cough cough - supported anymore. :D
(I noticed I opened a similar thread some years ago, too :o )

However, I have a very old notebook with Windows XP and Yawcam 0.6.2 still works, but Yawcam 0.7.0 stays frozen on the splash screen.

Running debug_start.bat I get:

java.version: 1.8.0_152
java.io.tmpdir: C:\DOCUME~1\MRWOLF~1\IMPOST~1\Temp\
user.home: C:\Documents and Settings\Mr Wolf
Max heap memory: 123M
base_path: C:\Documents and Settings\Mr Wolf\.yawcam\
File.separator: \
Local language: it
Time zone: sun.util.calendar.ZoneInfo[id="Europe/Berlin",offset=3600000,dstSavings=3600000,useDaylight=true,transitions=143,lastRule=java.util.SimpleTimeZone[id=Europe/Berlin,offset=3600000,dstSavings=3600000,useDaylight=true,startYear=0,startMode=2,startMonth=2,startDay=-1,startDayOfWeek=1,startTime=3600000,startTimeMode=2,endMode=2,endMonth=9,endDay=-1,endDayOfWeek=1,endTime=3600000,endTimeMode=2]]
Local time: 2021-05-20 17:04:56
copyFilesToUserDir()
Reading settings: C:\Documents and Settings\Mr Wolf\.yawcam\yawcam_settings.xml
Settings file version: 0.7.0
LookAndFeel: SYSTEM
fontDefault: java.awt.Font[family=Tahoma,name=Tahoma,style=plain,size=13]
fontDefaultMonospace: java.awt.Font[family=Monospaced,name=Monospaced,style=plain,size=13]
fontMainWindowLabels: java.awt.Font[family=Tahoma,name=Tahoma,style=plain,size=17]
Default font size: 13
CompatibleImageType: TYPE_INT_RGB (1)
Using ImageType: TYPE_INT_RGB (1)
Checking lock file: C:\Documents and Settings\Mr Wolf\.yawcam\yawcam-1.lck
ApplicationInstanceLock: I got ID: 1
Resolving public IP.
Passwords:
---------------------------------
---------------------------------
url 0 : http://www.yawcam.com/ver.dat
url 1 : http://home.bitcom.se/yawcam_files/ver.dat
Using ip check url: http://www.yawcam.com/ipq.php
Banned ip:
---------------------------------
---------------------------------
java.lang.UnsatisfiedLinkError: C:\Programmi\Yawcam\dsj.dll: Impossibile trovare la procedura specificata, Make sure the dsj.dll is on the library path & DirectX9 and WindowsMediaPlayer 9 or greater are installed
Exception in thread "main" java.lang.UnsatisfiedLinkError: de.humatic.dsj.DSEnvironment.registerDll(Ljava/lang/String;JJJ)I
at de.humatic.dsj.DSEnvironment.registerDll(Native Method)
at de.humatic.dsj.DSEnvironment.unlockDLL(SourceFile:529)
at yawcam.CamManager.<init>(CamManager.java:108)
at yawcam.Main.<init>(Main.java:352)
at yawcam.Main.main(Main.java:1607)
(IP check) Redirect to URL : https://www.yawcam.com/ipq.php
(version check) Redirect to URL : https://www.yawcam.com/ver.dat?ver=0.7. ... 2020-07-21
62.10.193.69
F: http://www.yawcam.com/ver.dat
F: http://home.bitcom.se/yawcam_files/ver.dat
0.7.0 == 0.7.0 -> 0

I've followed the procedure here:
https://www.yawcam.com/forum/viewtopic. ... 528#p12472
but it doesn't work.
The problem seems to be with file dsj.dll. The last Java version to install on Windows XP is 8 Update 152.
I'd just like to know if Yawcam 0.7.0 simply doesn't work on Windows XP.

Thanks.

Advertisement



Post Reply