3 instances of YC use up 100% memory after some time

Report and discuss bugs here!
Post Reply
nickshortie
Posts: 2
Joined: Sat Aug 13, 2022 11:34 am

3 instances of YC use up 100% memory after some time

Post by nickshortie » Sun Sep 25, 2022 3:10 pm

Hi,
I'm using Yawcam for a while now and I really like it. However I've got a problem with abnormal CPU usage and I think it's YC.
Here's the setup.

I'm using 3 instances of YC for 3 webcams with image upload via ftp every 60 seconds. I start the 3 YC via batch on PC startup:
c:
cd..
cd "C:\Program Files (x86)\Yawcam"

start Yawcam.exe
TIMEOUT /T 5
start Yawcam.exe
TIMEOUT /T 5
start Yawcam.exe

Everything works fine until after some time the CPU usage goes slowly up until 100%. ftp uploads are still working fine, it's only that cpu goes through the roof after some hours. That's why I did a log with perfmon. See the images for before/after and a 24h diagram of CPU and RAM usage.
If I close the 3 YC and start them again via batch everything is back to normal again.
Any ideas?

cheers, Nick
Attachments
yawcam_cpu_03.jpg
yawcam_cpu_03.jpg (109.81 KiB) Viewed 1194 times
yawcam_cpu_00.jpg
yawcam_cpu_00.jpg (22.13 KiB) Viewed 1194 times

Advertisement



malun
Site Admin
Posts: 1557
Joined: Sun Jan 04, 2004 1:29 pm

Re: 3 instances of YC use up 100% memory after some time

Post by malun » Mon Oct 10, 2022 4:07 pm

Strange!
What does your FTP settings look like in Yawcam?
/malun

nickshortie
Posts: 2
Joined: Sat Aug 13, 2022 11:34 am

Re: 3 instances of YC use up 100% memory after some time

Post by nickshortie » Fri Oct 14, 2022 1:05 pm

thx for replying. I deleted YC completely and configured 3 instances of YC from scratch and now everything seems to be stable for many days.
10% of cpu and 2,9GB of 8GB RAM in use. Might have had to do with the ftp though because I struggled with the settings and was getting some errors while setting up.
now the settings are: silent retry on connection error, upload temp filename and FTPES

nevermind, cheers,

Nick

malun
Site Admin
Posts: 1557
Joined: Sun Jan 04, 2004 1:29 pm

Re: 3 instances of YC use up 100% memory after some time

Post by malun » Wed Oct 19, 2022 9:52 pm

Okay. Great that it work as expected again!
/malun

Post Reply