Program won't open on start up

Report and discuss bugs here!
Post Reply
Banshee
Posts: 13
Joined: Sun Nov 21, 2004 8:32 pm

Program won't open on start up

Post by Banshee » Sun Nov 28, 2004 1:44 pm

This morning I went to run Yawcam on W2KPro machine and the program wouldn't load, the splash screen just stayed on the monitor, and nothing would happen from there. I had to use the Task Manager to get the splash screen off the monitor. After 3 re-boots, still no start up, so I un_installed the program, I did a regedit, and re-installed Yawcam and so far no problems. I also have JRE 1.5 on my machines. Now the other Win2k Pro machine has the same problem, but on this one I can't even get the add/remove programs to come up when I click on Yawcam. Both machines have the same OS and JRE 1.5

Advertisement



malun
Site Admin
Posts: 1530
Joined: Sun Jan 04, 2004 1:29 pm

Post by malun » Sun Nov 28, 2004 9:18 pm

Hmm... this doesn't sound good.

You don't need to use regedit to uninstall Yawcam! Just open control panel -> add/remove programs, select Yawcam and click delete.

On your "other computer", Yawcam doesn't show up in the list in add/remove programs? Or does it show up, but nothing happens when you click delete?

/malun

marks

my yawcam won't start now either

Post by marks » Wed Dec 08, 2004 1:53 am

Just like you, my yawcam suddenly will not start. I get the splash screen and then it just goes away. I have uninstalled, downloaded the latest, reinstalled and still the same thing. I have tried killing all processes and still won't run. I am on XP professional.

marks

more about yawcam won't start

Post by marks » Wed Dec 08, 2004 2:00 am

I notice now that it is generating an error log everytime it won't start. It begins like this:

#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x0b6d15cb, pid=3256, tid=3760
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0-b64 mixed mode)
# Problematic frame:
# C [P1120Vfw.dll+0x15cb]
#

--------------- T H R E A D ---------------

Current thread (0x0086d500): JavaThread "VFW Request Thread" [_thread_in_native, id=3760]

siginfo: ExceptionCode=0xc0000005, reading address 0x00000044
[/code]

Banshee
Posts: 13
Joined: Sun Nov 21, 2004 8:32 pm

Post by Banshee » Sat Dec 11, 2004 1:48 am

I have found that if I don't have any of the startup features set to start up when opening the program, I don't have any problems with the software.
I don't know why this is but i am ok with it.

malun
Site Admin
Posts: 1530
Joined: Sun Jan 04, 2004 1:29 pm

Post by malun » Sat Dec 11, 2004 11:06 am

Strange...
I'll look in to that and let you know if I find anything...

/malun

sky
Posts: 2
Joined: Sat Nov 27, 2004 1:07 pm

Post by sky » Mon Dec 13, 2004 2:27 pm

Sorry to report this bug also only now, but it's the same for me. :(

I didn't read the log (I'll do it soon) but if I enable the file saving option the applet stucks starting and with this option disabled all goes ok. (the other options doesn't give problems AFAIK).

If I start the applet with file saving disabled and enable it after all is started don't give problems also.
(this makes a full-quiet-startup impossible) :cry:

reminder:
1) check the log
2) check this bug with the new version (I'm using 0.2.3)

malun
Site Admin
Posts: 1530
Joined: Sun Jan 04, 2004 1:29 pm

Post by malun » Tue Dec 14, 2004 6:32 pm

I might have found a possible bug that causes this problem for some people... I let you know more soon :wink:

/malun

RedCity
Posts: 3
Joined: Thu Dec 16, 2004 5:37 pm

my yawcam won't start now either

Post by RedCity » Thu Dec 16, 2004 5:43 pm

Hi. Sorry to say, I have problem to get Yawcam to startup.
From the log:
#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x0b9a15cb, pid=304, tid=1508
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0-b64 mixed mode)
# Problematic frame:
# C [p1110vfw.dll+0x15cb]
#

--------------- T H R E A D ---------------

Current thread (0x0addec10): JavaThread "VFW Request Thread" [_thread_in_native, id=1508]

siginfo: ExceptionCode=0xc0000005, reading address 0x00000044

Registers:
EAX=0x00000000, EBX=0x000b2e30, ECX=0x00000028, EDX=0x00000000
ESP=0x0beaf650, EBP=0x0beaf658, ESI=0x77583710, EDI=0x000a7830
EIP=0x0b9a15cb, EFLAGS=0x00010246

Top of Stack: (sp=0x0beaf650)
0x0beaf650: 0b9a1c75 77583710 0beaf674 0b9a176a
0x0beaf660: 000a7830 00000000 0b9a1d50 00002010
0x0beaf670: 0beaf6fc 0beaf6a8 77564c2b 000b2e30
0x0beaf680: 0000000d 00001002 00002010 0beaf6fc
0x0beaf690: 00000000 00000000 00000000 0000000d
0x0beaf6a0: 0000000c 0000000d 0beaf6d8 77564b79
0x0beaf6b0: 000000c0 00001002 00002010 0beaf6fc
0x0beaf6c0: 00000001 7486ba3c 0000000d 00001002

Instructions: (pc=0x0b9a15cb)
0x0b9a15bb: c0 7d 05 6a 11 58 eb 2b 8b 55 0c 56 57 8b 7d 08
0x0b9a15cb: 8b 42 44 6a 0a 83 c0 30 59 8b f0 6a 0a f3 a5 59


Stack: [0x0be70000,0x0beb0000), sp=0x0beaf650, free space=253k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C [p1110vfw.dll+0x15cb]
C [p1110vfw.dll+0x176a]
C [WINMM.dll+0x4c2b]
C [WINMM.dll+0x4b79]
C [AVICAP32.dll+0xbdd4]
C [AVICAP32.dll+0x4506]
C [AVICAP32.dll+0x4558]
C [AVICAP32.dll+0x7653]
C [AVICAP32.dll+0x828f]
C [USER32.dll+0x1ef0]
C [USER32.dll+0x3523]
C [USER32.dll+0x6015]
C [jmvfw.dll+0x2113]
j com.sun.media.protocol.vfw.VFWSourceStream.doConnect()Z+75
j com.sun.media.protocol.vfw.VFWSourceStream.run()V+5
j java.lang.Thread.run()V+11
v ~StubRoutines::call_stub
V [jvm.dll+0x8168d]
V [jvm.dll+0xd4179]
V [jvm.dll+0x8155e]
V [jvm.dll+0x812bb]
V [jvm.dll+0x9bbe9]
V [jvm.dll+0xfe77f]
V [jvm.dll+0xfe74d]
C [MSVCRT.dll+0x85bc]
C [KERNEL32.DLL+0xb388]

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j com.sun.media.protocol.vfw.VFWCapture.capDriverConnect(II)Z+0
j com.sun.media.protocol.vfw.VFWSourceStream.doConnect()Z+75
j com.sun.media.protocol.vfw.VFWSourceStream.run()V+5
j java.lang.Thread.run()V+11
v ~StubRoutines::call_stub

--------------- P R O C E S S ---------------

Java Threads: ( => current thread )
=>0x0addec10 JavaThread "VFW Request Thread" [_thread_in_native, id=1508]
0x0adbbcd8 JavaThread "SplashThread" [_thread_blocked, id=1588]
0x0adba200 JavaThread "AWT-EventQueue-0" [_thread_blocked, id=1592]
0x0adaf020 JavaThread "AWT-Windows" daemon [_thread_in_native, id=1100]
0x0adaec28 JavaThread "AWT-Shutdown" [_thread_blocked, id=984]
0x0ad49930 JavaThread "Java2D Disposer" daemon [_thread_blocked, id=1152]
0x00a1c528 JavaThread "Thread-0" [_thread_blocked, id=148]
0x009dbc50 JavaThread "Low Memory Detector" daemon [_thread_blocked, id=1624]
0x009da758 JavaThread "CompilerThread0" daemon [_thread_blocked, id=1620]
0x009d9990 JavaThread "Signal Dispatcher" daemon [_thread_blocked, id=1480]
0x009d0e90 JavaThread "Finalizer" daemon [_thread_blocked, id=1240]
0x009cf9a0 JavaThread "Reference Handler" daemon [_thread_blocked, id=876]
0x00735d30 JavaThread "main" [_thread_in_vm, id=1484]

Other Threads:
0x009cb878 VMThread [id=1436]
0x009f6cf0 WatcherThread [id=1180]

VM state:not at safepoint (normal execution)
...

sky
Posts: 2
Joined: Sat Nov 27, 2004 1:07 pm

Post by sky » Thu Dec 16, 2004 9:39 pm

(relatively) "sorry" to say but... now the applet is working well. :shock:
I'm sorry that I don't exactly remember which configuration changes I've done... I've tryed to not change too many options at the time.

But...

1) enabling the log saving,
2) requesting the file-output and
3) putting the applet in auto-hide mode on startup

...now is working!

This foxy applet works well only if guarded (by logs) uh? :wink: :lol:

malun
Site Admin
Posts: 1530
Joined: Sun Jan 04, 2004 1:29 pm

Post by malun » Fri Dec 17, 2004 12:17 am

I have now made an attempt to fix the problem that Yawcam crashes when starting with the option "hide to traybar" for some users.

Please test if this new beta version works better:
http://www.yawcam.com/forum/viewtopic.php?t=156

/malun

RedCity
Posts: 3
Joined: Thu Dec 16, 2004 5:37 pm

Post by RedCity » Fri Dec 17, 2004 10:07 am

Nope, it didn't start for me... :cry:

malun
Site Admin
Posts: 1530
Joined: Sun Jan 04, 2004 1:29 pm

Post by malun » Fri Dec 17, 2004 11:35 am

I think that we are talking about two different problems here. Some users have problems with that Yawcam won't start when the option "hide to traybar at start" and the "start file output at startup" is selected. Other users can't get Yawcam to start at all.

RedCity> Which category of the above do you belong to?

I'll look in to the JMF registry exception you mentioned and see if I can find anything.

/malun

Guest

Post by Guest » Fri Dec 17, 2004 12:33 pm

I can't start Yawcam at all. Six months agoe i had no trubble...
At startup i can see the startpicture
Image
But then it just die...
The log say:

#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x0ba315cb, pid=1072, tid=1628
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0-b64 mixed mode)
# Problematic frame:
# C [p1110vfw.dll+0x15cb]
#

--------------- T H R E A D ---------------

Current thread (0x0ade5b98): JavaThread "VFW Request Thread" [_thread_in_native, id=1628]

siginfo: ExceptionCode=0xc0000005, reading address 0x00000044

Registers:
EAX=0x00000000, EBX=0x000acd18, ECX=0x00000028, EDX=0x00000000
ESP=0x0bf3f650, EBP=0x0bf3f658, ESI=0x77583710, EDI=0x000c0f60
EIP=0x0ba315cb, EFLAGS=0x00010246

Top of Stack: (sp=0x0bf3f650)
0x0bf3f650: 0ba31c75 77583710 0bf3f674 0ba3176a
0x0bf3f660: 000c0f60 00000000 0ba31d50 00002010
0x0bf3f670: 0bf3f6fc 0bf3f6a8 77564c2b 000acd18
0x0bf3f680: 0000000d 00001002 00002010 0bf3f6fc
0x0bf3f690: 00000000 00000000 00000000 0000000d
0x0bf3f6a0: 0000000c 0000000d 0bf3f6d8 77564b79
0x0bf3f6b0: 000000c0 00001002 00002010 0bf3f6fc
0x0bf3f6c0: 00000001 7486ba3c 0000000d 00001002

Instructions: (pc=0x0ba315cb)
0x0ba315bb: c0 7d 05 6a 11 58 eb 2b 8b 55 0c 56 57 8b 7d 08
0x0ba315cb: 8b 42 44 6a 0a 83 c0 30 59 8b f0 6a 0a f3 a5 59


Stack: [0x0bf00000,0x0bf40000), sp=0x0bf3f650, free space=253k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C [p1110vfw.dll+0x15cb]
C [p1110vfw.dll+0x176a]
C [WINMM.dll+0x4c2b]
C [WINMM.dll+0x4b79]
C [AVICAP32.dll+0xbdd4]
C [AVICAP32.dll+0x4506]
C [AVICAP32.dll+0x4558]
C [AVICAP32.dll+0x7653]
C [AVICAP32.dll+0x828f]
C [USER32.dll+0x1ef0]
C [USER32.dll+0x3523]
C [USER32.dll+0x6015]
C [jmvfw.dll+0x2113]
j com.sun.media.protocol.vfw.VFWSourceStream.doConnect()Z+75
j com.sun.media.protocol.vfw.VFWSourceStream.run()V+5
j java.lang.Thread.run()V+11
v ~StubRoutines::call_stub
V [jvm.dll+0x8168d]
V [jvm.dll+0xd4179]
V [jvm.dll+0x8155e]
V [jvm.dll+0x812bb]
V [jvm.dll+0x9bbe9]
V [jvm.dll+0xfe77f]
V [jvm.dll+0xfe74d]
C [MSVCRT.dll+0x85bc]
C [KERNEL32.DLL+0xb388]

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j com.sun.media.protocol.vfw.VFWCapture.capDriverConnect(II)Z+0
j com.sun.media.protocol.vfw.VFWSourceStream.doConnect()Z+75
j com.sun.media.protocol.vfw.VFWSourceStream.run()V+5
j java.lang.Thread.run()V+11
v ~StubRoutines::call_stub

--------------- P R O C E S S ---------------

Java Threads: ( => current thread )
=>0x0ade5b98 JavaThread "VFW Request Thread" [_thread_in_native, id=1628]
0x0adcc3e0 JavaThread "SplashThread" [_thread_blocked, id=1636]
0x0adb94a0 JavaThread "AWT-EventQueue-0" [_thread_blocked, id=1632]
0x0adaf3a8 JavaThread "AWT-Windows" daemon [_thread_in_native, id=1624]
0x0adaefb0 JavaThread "AWT-Shutdown" [_thread_blocked, id=1620]
0x0ad2fe78 JavaThread "Java2D Disposer" daemon [_thread_blocked, id=1616]
0x00a1c1d0 JavaThread "Thread-0" [_thread_blocked, id=1612]
0x009dbbf8 JavaThread "Low Memory Detector" daemon [_thread_blocked, id=1600]
0x009da700 JavaThread "CompilerThread0" daemon [_thread_blocked, id=336]
0x009d9938 JavaThread "Signal Dispatcher" daemon [_thread_blocked, id=1568]
0x009d0e38 JavaThread "Finalizer" daemon [_thread_blocked, id=1584]
0x009cf948 JavaThread "Reference Handler" daemon [_thread_blocked, id=668]
0x00735d40 JavaThread "main" [_thread_in_vm, id=1104]

Other Threads:
0x009cb820 VMThread [id=1132]
0x009f6c98 WatcherThread [id=1296]

VM state:not at safepoint (normal execution)

VM Mutex/Monitor currently owned by a thread: None

Heap
def new generation total 576K, used 540K [0x02aa0000, 0x02b40000, 0x02f80000)
eden space 512K, 93% used [0x02aa0000, 0x02b17100, 0x02b20000)
from space 64K, 100% used [0x02b20000, 0x02b30000, 0x02b30000)
to space 64K, 0% used [0x02b30000, 0x02b30000, 0x02b40000)
tenured generation total 2204K, used 1791K [0x02f80000, 0x031a7000, 0x06aa0000)
the space 2204K, 81% used [0x02f80000, 0x0313fe58, 0x03140000, 0x031a7000)
compacting perm gen total 8192K, used 7977K [0x06aa0000, 0x072a0000, 0x0aaa0000)
the space 8192K, 97% used [0x06aa0000, 0x0726a520, 0x0726a600, 0x072a0000)
No shared spaces configured.

Dynamic libraries:
0x00400000 - 0x0040c000 C:\Program\Yawcam2\jre\bin\yawcam.exe
0x77f80000 - 0x77ffe000 C:\WINNT\system32\ntdll.dll
0x794b0000 - 0x79512000 C:\WINNT\system32\ADVAPI32.dll
0x79880000 - 0x79936000 C:\WINNT\system32\KERNEL32.DLL
0x77130000 - 0x771a1000 C:\WINNT\system32\RPCRT4.DLL
0x77e10000 - 0x77e75000 C:\WINNT\system32\USER32.dll
0x77f40000 - 0x77f7b000 C:\WINNT\system32\GDI32.DLL
0x78000000 - 0x78045000 C:\WINNT\system32\MSVCRT.dll
0x6d640000 - 0x6d7c5000 C:\Program\Yawcam2\jre\bin\client\jvm.dll
0x77560000 - 0x77590000 C:\WINNT\system32\WINMM.dll
0x6d280000 - 0x6d288000 C:\Program\Yawcam2\jre\bin\hpi.dll
0x69030000 - 0x6903b000 C:\WINNT\system32\PSAPI.DLL
0x6d610000 - 0x6d61c000 C:\Program\Yawcam2\jre\bin\verify.dll
0x6d300000 - 0x6d31d000 C:\Program\Yawcam2\jre\bin\java.dll
0x6d630000 - 0x6d63f000 C:\Program\Yawcam2\jre\bin\zip.dll
0x6d000000 - 0x6d166000 C:\Program\Yawcam2\jre\bin\awt.dll
0x77800000 - 0x7781e000 C:\WINNT\system32\WINSPOOL.DRV
0x79950000 - 0x79960000 C:\WINNT\system32\MPR.DLL
0x75e40000 - 0x75e5a000 C:\WINNT\system32\IMM32.dll
0x77a50000 - 0x77b3f000 C:\WINNT\system32\ole32.dll
0x51000000 - 0x51050000 C:\WINNT\system32\ddraw.dll
0x72870000 - 0x72876000 C:\WINNT\system32\DCIMAN32.dll
0x5c000000 - 0x5c0c8000 C:\WINNT\system32\D3DIM700.DLL
0x6d240000 - 0x6d27d000 C:\Program\Yawcam2\jre\bin\fontmanager.dll
0x60000000 - 0x60045000 C:\WINNT\system32\MSCTF.dll
0x77590000 - 0x777d7000 C:\WINNT\system32\shell32.dll
0x772c0000 - 0x77329000 C:\WINNT\system32\SHLWAPI.dll
0x71710000 - 0x71794000 C:\WINNT\system32\COMCTL32.dll
0x10000000 - 0x10007000 C:\Program\Logitech\iTouch\iTchHk.dll
0x0b0f0000 - 0x0b103000 C:\Program\Browser Mouse\Browser Mouse\1.0\MOUSEDLL.DLL
0x0b130000 - 0x0b14e000 C:\Program\Delade filer\Logitech\Scrolling\LgMsgHk.dll
0x6d4c0000 - 0x6d4d3000 C:\Program\Yawcam2\jre\bin\net.dll
0x75000000 - 0x75014000 C:\WINNT\system32\WS2_32.dll
0x74ff0000 - 0x74ff8000 C:\WINNT\system32\WS2HELP.DLL
0x6d4e0000 - 0x6d4e9000 C:\Program\Yawcam2\jre\bin\nio.dll
0x77840000 - 0x7784c000 C:\WINNT\System32\rnr20.dll
0x77980000 - 0x779a4000 C:\WINNT\system32\DNSAPI.DLL
0x75020000 - 0x75029000 C:\WINNT\system32\WSOCK32.DLL
0x77330000 - 0x77343000 C:\WINNT\system32\iphlpapi.dll
0x77510000 - 0x77515000 C:\WINNT\system32\ICMP.DLL
0x0b1a0000 - 0x0b1b7000 C:\WINNT\system32\MPRAPI.DLL
0x75120000 - 0x7512f000 C:\WINNT\system32\SAMLIB.DLL
0x75140000 - 0x7518f000 C:\WINNT\system32\NETAPI32.DLL
0x79590000 - 0x7959f000 C:\WINNT\system32\Secur32.dll
0x77bf0000 - 0x77c01000 C:\WINNT\system32\NTDSAPI.dll
0x77950000 - 0x7797a000 C:\WINNT\system32\WLDAP32.DLL
0x75190000 - 0x75196000 C:\WINNT\system32\NETRAP.dll
0x779b0000 - 0x77a4b000 C:\WINNT\system32\OLEAUT32.DLL
0x773a0000 - 0x773cf000 C:\WINNT\system32\ACTIVEDS.DLL
0x77370000 - 0x77393000 C:\WINNT\system32\ADSLDPC.DLL
0x77830000 - 0x7783e000 C:\WINNT\system32\RTUTILS.DLL
0x78340000 - 0x783cf000 C:\WINNT\system32\SETUPAPI.DLL
0x792b0000 - 0x79311000 C:\WINNT\system32\USERENV.DLL
0x774d0000 - 0x77503000 C:\WINNT\system32\RASAPI32.DLL
0x774b0000 - 0x774c1000 C:\WINNT\system32\RASMAN.DLL
0x77520000 - 0x77542000 C:\WINNT\system32\TAPI32.DLL
0x77350000 - 0x77369000 C:\WINNT\system32\DHCPCSVC.DLL
0x777e0000 - 0x777e8000 C:\WINNT\System32\winrnr.dll
0x777f0000 - 0x777f5000 C:\WINNT\system32\rasadhlp.dll
0x74fa0000 - 0x74fbe000 C:\WINNT\system32\msafd.dll
0x74fe0000 - 0x74fe7000 C:\WINNT\System32\wshtcpip.dll
0x0b6e0000 - 0x0b6f5000 C:\Program\Yawcam2\jre\lib\ext\jmutil.dll
0x0b850000 - 0x0b85d000 C:\Program\Yawcam2\jre\lib\ext\jmvfw.dll
0x74860000 - 0x74873000 C:\WINNT\system32\AVICAP32.dll
0x77820000 - 0x77827000 C:\WINNT\system32\VERSION.dll
0x75990000 - 0x75996000 C:\WINNT\system32\LZ32.DLL
0x6a860000 - 0x6a880000 C:\WINNT\system32\MSVFW32.dll
0x77550000 - 0x77558000 C:\WINNT\system32\wdmaud.drv
0x773f0000 - 0x773f8000 C:\WINNT\system32\msacm32.drv
0x77400000 - 0x77413000 C:\WINNT\system32\MSACM32.dll
0x0ba30000 - 0x0ba4d000 C:\WINNT\system32\p1110vfw.dll
0x770a0000 - 0x770a7000 C:\WINNT\system32\CFGMGR32.dll
0x69570000 - 0x69599000 C:\WINNT\system32\OLEPRO32.DLL
0x68cb0000 - 0x68d40000 C:\WINNT\system32\CLBCATQ.DLL
0x35500000 - 0x35659000 C:\WINNT\system32\quartz.dll
0x1c200000 - 0x1c22e000 C:\WINNT\system32\qcap.dll

VM Arguments:
java_command: yawcam.Main

Environment Variables:
PATH=C:\WINNT\system32;C:\WINNT;C:\WINNT\system32\WBEM;C:\Program\ATI Technologies\ATI Control Panel;C:\Program\Executive Software\Diskeeper\;C:\Program\Symantec\pcAnywhere\
USERNAME=Administratör
OS=Windows_NT
PROCESSOR_IDENTIFIER=x86 Family 6 Model 10 Stepping 0, AuthenticAMD


--------------- S Y S T E M ---------------

OS: Windows 2000 Build 2195 Service Pack 4

CPU:total 1 family 6, cmov, cx8, fxsr, mmx, sse

Memory: 4k page, physical 261620k(62552k free), swap 631376k(355308k free)

vm_info: Java HotSpot(TM) Client VM (1.5.0-b64) for windows-x86, built on Sep 15 2004 03:00:31 by "java_re" with MS VC++ 6.0


RedCity
Posts: 3
Joined: Thu Dec 16, 2004 5:37 pm

Post by RedCity » Fri Dec 17, 2004 12:58 pm

Oh, i wasn't logged in. :oops:
I was the previus "Guest".

Post Reply