FIXED - Flickering video Logitech HD Pro WebCam C920

Questions? Suggestions? Need help? Talk about anything related to Yawcam...
Post Reply
poetal
Posts: 1
Joined: Mon Jul 18, 2016 7:48 pm

FIXED - Flickering video Logitech HD Pro WebCam C920

Post by poetal » Sat Sep 02, 2017 7:14 pm

Flickering issue fixed FINALLY!! I just watched a YouTuber explain that my Logitech driver should not be used and to use the Microsoft one already installed on my computer.

Short answer: Start > Device Manager > Imaging Devices > Logitech HD Pro Webcam C920 > (right click) Properties > Driver > Update Driver > Browse my computer for driver software > Let me pick from a list of device drivers on my computer > USB video device > Reboot!

Long answer: Basically, go to the Start button and type in "device manager" and choose it. Open the drop down for "Imaging Devices" and then right click "Logitech HD Pro Webcam C920" and choose "Properties". Go to the "driver" tab and choose "update driver" and then "Browse my computer for driver software" then "Let me pick from a list of device drivers on my computer". Choose "USB video device" instead of the Logitech driver. Then simply reboot your machine and it'll work.

I would like to thank the Youtuber who gifted this knowledge https://youtu.be/5rEBXJKMi4k
I did not need to use all his advice in the video just the driver stuff.

Advertisement



pjacob
Posts: 1
Joined: Wed Oct 16, 2019 4:17 pm

Re: FIXED - Flickering video Logitech HD Pro WebCam C920

Post by pjacob » Wed Oct 16, 2019 4:21 pm

Thank you! This fixed my problem! :D

Post Reply